Mercedes 280E Auto (Petrol) Running Problem

Discussion in 'E Class' started by Mark Lilley, Jul 4, 2005.

  1. Mark Lilley

    Mark Lilley Guest

    Please can somebody help

    I have a 1994 280E Auto (petrol) estate which suddenly lost a lot of
    performance.

    1/. The engine won't idle at all.
    2/. Once started I have to keep it alive with the throttle or the engine
    will stall.
    3/. It won't rev above 4000 rpm. If the engiine approaches these revs the
    engine begins to stumble and will cut out even while driving.
    4/. There is a strong smell of unburnt fuel at idle, like the fuel
    mixture is wrong.

    I am thinking the EMU might have defaulted into a "Get Home" mode...If this
    is correct can it be reset and how?

    Kind Regards

    Mark Lilley
     
    Mark Lilley, Jul 4, 2005
    #1
    1. Advertisements

  2. On 2005-07-04 04:30:10 -0700, "Mark Lilley" <> said:

    > Please can somebody help
    >
    > I have a 1994 280E Auto (petrol) estate which suddenly lost a lot of
    > performance.
    >
    > 1/. The engine won't idle at all.
    > 2/. Once started I have to keep it alive with the throttle or the
    > engine will stall.
    > 3/. It won't rev above 4000 rpm. If the engiine approaches these
    > revs the engine begins to stumble and will cut out even while driving.
    > 4/. There is a strong smell of unburnt fuel at idle, like the fuel
    > mixture is wrong.
    >
    > I am thinking the EMU might have defaulted into a "Get Home" mode...If
    > this is correct can it be reset and how?

    It could just be miss firing for any reason....

    Pull the plugs and examine them, work from there...

    Marty
     
    Martin Joseph, Jul 6, 2005
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Jim Shelton

    280E auto

    Jim Shelton, Jan 12, 2004, in forum: E Class
    Replies:
    2
    Views:
    282
    Rob. Smith
    Jan 12, 2004
  2. Mark Lilley

    1995 280E Idle Problem

    Mark Lilley, Jan 28, 2004, in forum: E Class
    Replies:
    1
    Views:
    301
    T.G. Lambach
    Jan 28, 2004
  3. steve berriman

    1979 280E auto up for grabs

    steve berriman, Jul 4, 2004, in forum: E Class
    Replies:
    0
    Views:
    379
    steve berriman
    Jul 4, 2004
  4. Ian Jackson
    Replies:
    4
    Views:
    310
  5. shortyone

    1990 mercedes 190E petrol 2.0

    shortyone, Aug 31, 2005, in forum: E Class
    Replies:
    4
    Views:
    347
    Pieman
    Sep 5, 2005
  6. Buzby

    petrol 320e running costs

    Buzby, Jun 7, 2006, in forum: E Class
    Replies:
    6
    Views:
    300
    t avanas
    Jun 12, 2006
  7. logicworkshop

    Sprinter Petrol Smell Problem

    logicworkshop, Apr 20, 2008, in forum: General Motoring
    Replies:
    1
    Views:
    189
    Bruce
    Apr 20, 2008
  8. maddog
    Replies:
    2
    Views:
    428
    -->> T.G. Lambach
    Apr 20, 2008
Loading...