Mercedes-Benz Car Forums


Reply
Thread Tools Display Modes

E320 Front Spring Mount

 
Ken Bleau
Guest
Posts: n/a
 
      01-03-2004
Hey all, just had my front spring mount snap (practically) off on my 1997.
Looking at it, it looks like the weld rusted through. Even pristine, it
appears to be a pretty cheezy mount, lite guage metal welded to the frame. I
am having a friend bend and weld it back into place.
Question;
Is this common for this type of failure? Does anyone know of any recalls
reguarding this isssue? I believe my 83 is bolted through the frame, why
would MB change to a weld?
Regards to all,
Ken


 
Reply With Quote
 
 
 
 
Randy S
Guest
Posts: n/a
 
      01-05-2004
Had the same happen to my 1997 E420. Couldn't believe it. Dealer claimed it
was "common in the midwest with all the salt and snow". What? Fought tooth
and nail with the dealer, they paid half of the nearly $2000 repair bill. (MB
dealer couldn't repair it; they sent it to a 3rd party body shop).

Randy


>Hey all, just had my front spring mount snap (practically) off on my 1997.
>Looking at it, it looks like the weld rusted through. Even pristine, it
>appears to be a pretty cheezy mount, lite guage metal welded to the >frame. I

am having a friend bend and weld it back into place.
>Question; Is this common for this type of failure? Does anyone
>know of any recalls reguarding this isssue?



 
Reply With Quote
 
 
 
 
Ken Bleau
Guest
Posts: n/a
 
      01-05-2004
I think it was a bad day in Stuttgart.
I haven't gotten the bill yet, but my body shop friend is welding it back in
place. I checked the other mounts and they all looked good, then again, so
did this one before it let go.
My 83 300d will never have this problem due to the fact that the spring
mount is incorporated into the frame, very nice. I am thankful it snapped a
block from my house and that it was during a "gentle" application of the
brakes at a stop sign.
I (in general) don't trust dealers as far as I can spit (with the wind in my
face). I am hopeful that this is anomaly , not an omen.
I am going to try out some POR 15 when the north east winter has eased it's
clammy grip but . . . that is another thread :-)
Thanks for the reply
Ken

"Randy S" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Had the same happen to my 1997 E420. Couldn't believe it. Dealer

claimed it
> was "common in the midwest with all the salt and snow". What? Fought

tooth
> and nail with the dealer, they paid half of the nearly $2000 repair bill.

(MB
> dealer couldn't repair it; they sent it to a 3rd party body shop).
>
> Randy
>
>
> >Hey all, just had my front spring mount snap (practically) off on my

1997.
> >Looking at it, it looks like the weld rusted through. Even pristine, it
> >appears to be a pretty cheezy mount, lite guage metal welded to the

>frame. I
> am having a friend bend and weld it back into place.
> >Question; Is this common for this type of failure? Does anyone
> >know of any recalls reguarding this isssue?

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
W210 Front Spring & Upper Perch Tiger General Motoring 0 08-14-2011 06:04 PM
Front Spring Perches Buster General Motoring 4 06-15-2008 01:12 PM
1997 e420 Front Right Coil Spring Crack Kelly General Motoring 2 08-31-2007 02:17 PM
FS: truck-mount cd changer from my '97 E320 Cheesehead Mercedes-Benz Parts For Sale / Trade 3 10-24-2005 11:37 AM
noise front left spring rperkins General Motoring 2 05-19-2004 05:52 PM


All times are GMT. The time now is 03:29 PM.